MetaCDN - StreamShark

Using the WordPress W3 Total Cache CDN plugin with MetaCDN

Step 1: Download and install plugin

In the left panel, select Add New from Plugins, search for W3 Total Cache and click Install Now from the relevant search result. (in our case, it's already Installed)

Screen_Shot_2013-07-09_at_5.10.55_PM.png

 

After installation has completed, click on the Activate Plugin link to activate the plugin.

 

Step 2: Enable CDN

Go back to the Plugins page, click on Settings for the newly installed W3 Total Cache plugin, then scroll down to CDN part of the page. Enable CDN by checking the check box, and choose Generic Mirror from CDN Type drop down list.  The next step is to configure the plugin to use your MetaCDN accelerated site url.

Screen_Shot_2013-07-10_at_8.54.09_AM.png

Step 3: MetaCDN Configuration

There are many settings available for W3 Total Cache plugin, but for the MetaCDN powered site accelerator to work only two things needs to be changed.

Screen_Shot_2013-07-10_at_8.58.22_AM.png

Click CDN in the menu on the left and scroll down to the Configuration section. Select Disabled (always use HTTP) for SSL support, copy your site's MetaCDN Accelerated URL (***.sa.metacdn.net) into the field labeled Replace site's hostname with, then click the Add CNAME button. Finally, click on Save all Settings. You can test the correctness of your Accelerated URL by clicking on the Test Mirror button.

step2.1.png

After plugin configuration being updated, Empty the page cache will make sure all previous cached data being invalidated.

step2.2.png

Step 4 - Save all settings

Click on the 'general' tab and click on 'Save all settings' within the CDN section.  If all is well, you should see a message saying the plugin is enabled. 

 

Troubleshooting

I've set up the plugin as directed, but my url is not being rewritten with the accelerated url.  What gives?

There are a number of possible causes for this.  The most common are bad wordpress plugins and bad theme code.  

If you have a number of plugins enabled, try disabling them one by one whilst reloading your page to check whether a plugin is the issue.

In some older themes, header.php may contain some dodgy code that opens the output buffer without closing it afterwards.  For example (ob_start() opens the buffer):

<?php if (substr_count($_SERVER['HTTP_ACCEPT_ENCODING'], 'gzip')) ob_start("ob_gzhandler"); else ob_start(); ?>

This can interfere with the rewriting stage of the cache plugin.  Remove any such lines from your theme header.php and reload your page to see if rewriting starts working correctly.  In this case, w3 total cache can gzip responses so there is no need for this line in the theme file.

Have more questions? Submit a request